joe_brooks43

GE Induction Range Problem

Joe Brooks
April 20, 2015
last modified: April 20, 2015

I submitted this in the Kitchen forum yesterday, and one of the comments suggested I post it here. This is my first visit since Houzz took over and made a navigation error. Anyway, I have owned the range for the better part of a year and have been very happy until the issue described below happened. I would certainly appreciate any information you have to share.

I have a GE PHB920SFSS induction range that I bought last summer.
It worked great until a couple of months ago when my wife had a couple
of instances where she would turn on a hob and it would turn itself off
after a few seconds. It was an intermittent issue and of course when I
tried it it worked fine. After a few weeks I finally had it happen to
me, but it was still a rare occurrence and we could still cook on it
pretty worry free.

Then last night just as dinner was almost finished the range quit.
All the hobs would work for at most a few seconds then turn off. I
turned the power off at the circuit breaker then back on after a minute
or so. When I tried to turn of a hob it turned off and the clock
displayed a FA92 error, whatever that is. We had baked some cornbread
at 400 Degrees before the error occurred. The owners manual says that
an F*** error can occur if the range is overheated so I opened the oven
so it could cool down and a few minutes later I was finally able to get
one hob to stay on.

The range worked fine for breakfast this morning. But then dinnertime came around again.

Dinner tonight is a strictly stove top affair. Right from the start
we could not get the hob to stay on. Finally I again cycled the power
at the circuit breaker. The first time I tried the range after turning
the power back on I got a FA92 error. A few minutes later I was able to
get a hob to stay on. My wife hasn't hollered at me so I guess it is
still working.

Has anyone had a similar problem with their range? Or heard about such a problem?

I will call for service tomorrow but I am afraid the problem is still too intermittent for GE to take it seriously.

Any advice is appreciated.

Comments (170)

  • Lisa Sears

    Hi Les,

    Thanks for all of your help!

    I am also wondering if my problem is the Generator Board ASM, as above or possibly the Control UI ASM as neither my burners nor my oven will stay on. The left rear burner still hums like it's trying to work, but then quits, but none of the others do. The oven starts to preheat, but then quits. Also, the Generator Board ASM is on back order until JUNE 29th!! My model is PHB920SF2SS.

    Thanks again,

    Lisa

  • Les Garten

    Lisa, hopefully the manual can help you out with the troubleshooting. I have a 920 as well.

  • Related Discussions

    Need help choosing induction range

    Q

    Comments (11)
    Our remodel will be done any day and the new Jenn Air induction range has not been released (over a year late). I am still holding out for that one and purchased an electric range on Craigslist and will wait a few months longer. If no JA release is in sight, we will likely go with the Bosch induction as we have a Bosch dishwasher and refrigerator. The JA has a much bigger oven than Bosch and lower drawer with a handle. The Samsung induction looks good with the double oven interior option. The oven vents to the front just behind the oven door handle which is the reason I haven't gone with that one. It looks great and I think the ability to heat and use a smaller oven space would be a very useful feature. If the JA is not in the cards, I am very encouraged that people seem to really like their Bosch ranges.
    ...See More

    induction range???

    Q

    Comments (9)
    No oven mounted underneath; we've got separate wall ovens. Replaced the previous owner's gas cooktop with the induction, so all my research involved cooktops, no ranges. I do think ours needs about a foot of clearance underneath if I recall correctly. Although I also recall seeing something about ovens being mounted underneath and just double-checked the manual for you. Quickly glanced through and it mentions not to use the cooktop if an oven beneath is in self-clean mode, so maybe it is possible with the GE or it's just the usual legal jargon. Stuck my head under ours in the island and it is shallow, think an oven could fit underneath, except for a metal cord tube sticking out, but maybe that could be mounted differently depending on where your electrical line input is. And that twelve inch clearance thing I saw may have been related to the downdraft. Not sure, but know somewhere in my cleaning/unpacking endeavors I saw that for one of the two. I don't recall researching the Miele, maybe it was out of our price range. If you have to do a range, I was really pleased with our Samsung we purchased new at our old house. It was electric though, so not sure how their induction is. Highly recommend going the induction route, one way or the other. Let me know if there's anything else I can help answer. Can be hard finding info since relatively few people still have it.
    ...See More

    36" or 42" Induction Range - do such things exist?

    Q

    Comments (82)
    Glad I found this post! I am currently dealing with an error in judgement when ordering my cabinets. I have a space between my cabinets for the range - 36". We don't have gas in our building - so are the 36" Verona electric range and 36" Wolf indication range my only options? The Verona is around $3000 and Wolf over $9000. I have never heard of Verona and scared to go with an unknown brand. Does the Wolf need two circuits? I know nothing about any of this - please advise. thanks!
    ...See More

    30 inch induction slide in range: Bertazzoni or Bosch Benchmark series

    Q

    Comments (4)
    I bought a gorgeous Bertazzoni and it is the worst purchase I think I have ever made. It is sad- I fell for a pretty face. Bertazzoni does not stand behind their products, which are inferior. You will see comments from Berta on these websites saying they want to hear about any issues, which is laughable; they will never get back to you. I would give anything for a simple Whirlpool, GE or other blah looking but reliable stove. Next purchase!
    ...See More
  • Lisa Sears

    Hi Les,

    I haven't gotten anything in my email. Did you send it out yet?

    Thanks!

  • Les Garten

    I just resent it. For some reason it went to someone named mnovak

  • Lisa Sears

    Got it! Thanks! What do you think about the 2 different controller boards? Was yours doing the same thing (oven and burners not working)? Trying to figure out which part to order...

  • PRO
    Intec
    You know how that goes, once we repair something, we often say, "why, that was easy". I'm an electronic technicia, who likes taking stuff apart, although, I do refrain from doing so if it's working OK.
    My pictures should help to see how I narrowed down the problem.
    The first step in troubleshooting is to read the fault codes shown in the service manual fault table.
    I discovered that the error code, which I talk about in my previous posts, pointed me to the cooktop RR induction coil had a problem. When I removed & inspected the Induction coil wiring terminals, I noticed a loose spade terminal of the red wires connecting it to the generator board. Anytime you have a high current device, that has a loosely secured wire lug at it's power source (generator board), the loose connection will build up carbon, and struggle to obtain the current & voltage its being commanded to heat to. I found that if you follow the troubleshooting advice in the service manual, and power down the oven for 3-5 minutes, and use the 3-butron key combination to enter the service state, you can reset the ROM error codes. By clearing the error codes, the GE oven will allow you to proceed as if there's nothing wrong. However, as soon as you command the defective see too do heat up, then the onboard computer will register that fault again, then auto-shut off all fun tion commands that follow. I could've kept my wife's GE oven usable, as long as I had first cleared the faults stored in ROM (read-only-memory), and not attempted to issue a command to the cooktop RR heating coil.
    It only costs me $240, for I was able to strip-back the coil wire and crimp/solder a new spade-lug onto the red wire, and at the same time, replaced the GE Generator Board.
    GE Parts Supply were too slow to ship me my parts, which are due to arrive this Saturday.
    I plan to refuse the shipment of these 2 parts: generator board & RR induction coil.
    If someone is wanting to buy them from me, and not have to order them from a slow GE warehouse, then let me know by emailing me @ barrypickens@yahoo.com, or send me a private Facebook message.
    Just look me up on Facebook, Texas, with that email address. I will edit my this post by Saturday.
  • Les Garten

    bnlsears Mine was doing a lot of weird things, the first one that is. It was fork lifted out under warranty and replaced after replacing everything in it piecemeal twice! The cool part is that when they give you a part and that wasn't the problem, keep the part! I have some spares.


    Last problem I had on the new stove was the burnt power relay board in the back of the unit. That was after a Self Cleaning :-(

    It has had once or twice a shutoff.

  • PRO
    Intec
    Lisa, your oven's symptoms sound like mine.
    Any fault will cause the oven and other commands to only stay on for 2-3 seconds.
    Take a look at my photos, and I have more online if you want to see them.
    I recommend you disassemble the top section and inspect the wiring from each coil where they connect to the generator boards.

    Per the service manual, use a ohm meter to check each coil's copper wire continuity which should read less than 1 ohm. Also, check the ohms of the temperature sensor that's identifiable as the small 1" resistor looking device that is moounted on each element's top center. The resistance ohm reading is read by using a small wire inserted in the end of the white wiring harness connectir attached to the coil element (hot plate). If you don't have a small wire, use a pin or needle to insert in the white 2-pin connector, then you'll have a place e to temporarily connect your ohm meter to. The resistance should read about 100k, and slowly decrease when you touch the sensor with your finger for a few seconds.
    My cooktop RR coil's red wire terminal was loose under it's screw terminal at the Generator Board. This caused the generator board to overheat, ruining the board. This failure generated a failure code, which in turn, would not allow oven commands to work, nor any heating commands of cooktop burner elements to work.
    So, I suspect you have a cooktop element or Generator Board failure.
    Now, since I'm the person who likely depleted GE's last stocked Generator Board, it might explain why you can't order the board. I couldn't wait on GE to supply me with this board, so I ordered the last one that 1stServe had in stock.
    My GE order is due tomorrow, Saturday, of which I plan to return for credit. If you want to not wait, I will sell you my order and ship it to you direct. Here is what you would owe me:

    GE Induction Oven, model PHS920SF1SS
    I ordered from GE Appliance Parts website, https://www.geapplianceparts.com

    1) 1 ea. of item 8, BOARD GENERATOR ASM, GE part number WB27X27183, $221.00
    2) 1 ea. of item 59, ELEMENT INDUCTION 1800W, GE part number WB30X21489, $164.00.

    Some of GE's parts are interchangeable with other GE Induction ovens.
  • Lisa Sears
    Hi Intec!

    Well, I squeaked a bit (referencing a Service Bulletin from Sept. 2016 that I found) and GE is sending me the Generator Board for free (part WB27X27183). Only 2 problems with that... it is on backorder until June 29th is the first issue. Maybe when they receive yours back they’ll send it to me ;-)

    The other is that I called and had a GE Tech come out. He said that since the service bulletin called for the whole induction tray (WB27X27186) and those are available (56 in stock), he’s not allowed to replace just part of it and must do the whole thing! That’s not what they’re sending me, so now I have to squeak again! Actually, you get more flies with honey (and some background research) than vinegar, so I will call and ask nicely! He also doesn’t charge another house call fee if he does it within 30 days.

    On a more positive note, when I clear the error codes my oven does work again!

    Thanks for ALL of your help!

    Lisa
  • Les Garten

    Lisa, can you point us to that service bulletin?

  • PRO
    Intec

    Lisa, this is awesome! Your's must've still been under warranty?

    We purchased our GE Induction Oven in 2014, and GE didn't offer us this free change out, which they offered you.

    After several email exchanges with their GE Appliances Consumer Relations department, she told me GE didn't have a technician in the Corpus Christi TX area. Of course, I didn't push against GE as well as you did. My $220 was worth my invested troubleshooting time, which will assist me in repairing any future issues with this induction oven.

    Thanks,

    Barry

  • Lisa Sears
    Actually it isn’t under warranty, as it was put in a new home build that we closed on in January 2016. I think they bought it in Sept. 2015.

    So now I will wait until tomorrow and see if I can get the entire induction assembly instead of just part of it ;-)
  • PRO
    Intec

    Lisa, I'm sure you'll be pleasantly surprised with the results. I know my wife and I were whenever the generator board was all we needed to do self-repair on!
    My GE parts arrived Saturday, so GE issued us RMA number to return the unneeded parts for full credit. They actually duplicated (double-billed) my parts order, so I've got to return two orders to GR.

  • mnovak99

    Anyone try the steam clean on this range? I only had a few minor splatters so I just tried steam clean on mine and it was pretty much a joke. Poured a cup of water in as directed and set it to steam clean. It did it's thing for 30 minutes and signaled it was done. When I opened it there was still at least a 1/2 cup of water in it and it really didn't do anything. Ran for another 30 minutes and still same thing. Splatter didn't soften up at all. I ended up using some Barkeepers friend and a sponge to clean it.

    My range is actually the Cafe version but it is basically the same as the Profile.

  • Adam Cook

    Could somebody please send me the service manual mentioned in this thread?


    We have a PHS920SF1SS that has been failing intermittently for about 2 years now but the problem has gone worse.


    Always failure code FA92. A power cycle used to fix it but now 3-4 power cycles later the error still occurs.


    I think I'm handy enough to replace the generator board is that is all that is needed but I would like to have the manual.

  • helenl553

    I have the same stove that you have and I have the same problems as you. I bought my GE Induction range 4 years ago. Installed into a brand new home. I didn't actually get to move into this house until this past March. So, the stove is about 4 years old with 4 months of use. I have been having the same issues as you for the past 3 months. Last night none of the burners would stay on, ruining another dinner. Shut the stove off at the panel and turned back on. Got the FA92 code and then the burner would not stay on again. Naturally my warranty has expired. I waited on GE Consumer Relations line for 20 minutes with no one picking up. The service department couldn't find the FA92 code. From what I am reading online here, I think I am needing to buy another stove, but it will not be a GE. I am in new construction with 200 amps to the house and it is on a 50amp breaker. Sometimes I think the problem is in trying to wipe down the control panel makes it wonky. I have done the LOCK on the panel, but still see the lights flashing when I wipe the controls.

    Did you ever find out what FA92 meant? I love induction and have spent a good chunk of change on new pans. I don't want to give up on induction, but I am also not going to shell out $1500 for a part either. I have read posts on Google with many people replacing the control board only to have it fail again.


    Keep up posted and so will I.

  • Joe Brooks

    I feel your pain, Helen. I went a few rounds with GE support a couple of years ago and eventually they offered to sell me a new range for $500 including installation of the new range and haul-away of the old one. If you are persistent hopefully you can achieve a similar or better outcome.

    I didn't follow through on their offer because we have become dependent on the oven temperature probe in our oven, and GE didn't offer any new models with that feature. For us, as long as the range doesn't fail at Thanksgiving or Christmas, we'll just live with it.

  • Adam Cook

    You can find the induction error codes here (second chart down): https://www.manualslib.com/manual/762862/Ge-Phb925sb1ss.html?page=60

    FA92 indicates a failure of the temperature sensor on the 2nd induction element (the big one).

    I found some screenshots on another website for how to disassemble the control panel and the cooktop assembly. I've saved those here in a Dropbox link in case you'd like to try it. It's not terribly difficult. Just time consuming and you need to keep track of what goes where for reassembly: https://www.dropbox.com/sh/fn7lbtx11nmfne0/AADTt3F0tMLyujw5qiJulrpHa?dl=0

    We ended up disassembling our stove and manually inspecting this sensor and all the connections. The sensor is the component on the top of the induction coil. It's a thermistor and if it's functioning properly its resistance (ohms) will change with temperature. This is easy to check with a multimeter. Measure the output and put your hand on the thermistor and you'll see its ohm value change as it warms up.

    Nothing looked wrong with either the control board or any of the sensors (we measured all 4 just to be safe). So we reassembled and the stove has worked fine for the past week. I am hoping that since the issue was intermittent that there was simply a bad connection between one of the sensors and the control board.

  • jburger8too

    I have 4 year old range. Both oven and stovetop turn off intermittently. Have independent technician researching the issue. If anyone has a solution, please let me know.

  • Jenny Lee
    I’ve had the induction assembly replaced twice already and it’s failing again. The first two times I’ve had issues, it was just the burners would go on, then almost immediately turn off. Now, the oven also won’t work. Range is 4 years old and starting failing at year 1.

    I keep purchasing the extended warranty (~$80/year) which infuriates me! They did say if I pay for the fix out of pocket (my tech says ~$800 for the assembly, his time/service call) then this defect will be warranted for 5 years.

    It’s sad but it’s probably time to scrap this thing and buy a new range. Or, do I demand the tech replace every part, as I read someone earlier did? Seems like no one is having luck with GE Louisville making this right?
  • kevinande

    Seems to me you have two options. Keep renewing the warranty or replace the unit. Both of which you already realize. I see nothing but negative reviews on these models especially the Cafe series. I also recommend you stay away from any model made by Samsung. I personally have a Frigidare Professional series cook top that has performed admirably with no issues. I actually wanted a Thermadore Freedom, however it has a host of negative reviews as well. I have a Whirlpool induction range in a rental property that I have had 0 issues out of. The model # escapes me at the moment, but if you like the next time I am over there I will get it for you,

  • Marie M
    Update for those of you still discovering the details of this lemon & Kudos to those of you who have taken the thing apart and put it together again. GE didn’t even know how to do that back when ours first failed, which is fairly disturbing anyway - I mean, who put it together the first time?! Our replacement stove from 2014 is still alive for now, although it does click occasionally at low settings. Our 5 year warranty will expire this year, which means we will renew it or likely it’ll fail the day after the warranty runs out. As long as we own it, we’re just living with the risk that we may suddenly get to order a pizza. Does anyone have a new favorite induction stove yet so we can be prepared for the day it fails again?
  • mnovak99

    You may want to consider the GE Cafe Induction range (CHS995SElSS). It looks like they may have finally worked out all the kinks in your model. You can get in in single or double oven. I have the double oven and have been very pleased for over a year now. There is an owners discussion on houzz over here: https://www.houzz.com/discussions/ge-cafe-induction-range-questions-dsvw-vd~5031170

  • waverly6

    @mnovak99, that is the model I was looking at but after reading through this thread I was going to start my search over again. and possibly just go back to the option of getting the induction cooktop and separate convection oven. Will look at the thread you references.

    Edit. I see the thread you referenced is one I had been looking at. So this is a completely different model. iIm in analysis paralysis now.

  • catherine_sanderson1
    I have a GE profile induction cooktop...it’s been in use for over a year. This week the large burner crapped out. Not a cheap buy. Any one know of a recall?
  • jakret

    I have had the same issues since we bought the GE Profile range in 2012. Whenever we are doing alot of cooking like Thanksgiving it will start to shut down but when all the lights go out it will come back on. But that sometimes takes 30 min. In the begining I thought it had something to do with Sabbath mode but the repairman we called said it might be the electronic board that costs $1000. but he wasn't sure that would fix it. The repairman also called GE and they said not to cook on high and not to use more than 2 burners and not to use the self cleaning mode. We have also had the breaker checked out and the electrical wire coming to the range, our breaker is an 50amp and the wiring also checked out. In reviews this is not the first time I have heard this same complaint. I am in the process of trying to replace this range, I love the induction and will stick with that but with a different brand. I really like the bosch except for the burner placement. Good luck with GE.

  • HU-194475573

    Hi, I have a GE Profile induction range model #PCHB920SM1SS that is less than a year old and I have had 3 repairmen in to try to make sense of it. The basic problem is that it takes forever for the oven to warm up. I have had large capacity ovens with hidden bake elements, so I know from experience that they are notorious for taking a long time to preheat BUT...... In the hopes that someone else out there has experienced the same issues, here goes! Whenever I start the oven to preheat at 350 degrees, after 9 minutes the buzzer indicates the oven has reached temp. At first I thought WOW!! what a great range, it preheats so fast. Then after my first attempt at baking bread in the new oven, I saw that there was definitely an issue. Went out, bought an oven thermometer, placed it in the oven and sure enough found that the actual temp. of the oven that signalled me it had reached 350 deg. after 9 min. had in fact only reached 200 degrees. Called in , they sent a repairman, he told me to calibrate the oven the maximum 30 degrees in the negative.....yes, decrease the oven by 30. I told him it seemed counterintuitive to decrease calibration in an oven that seemingly is underheating, but what do I know. So | tried that and of course the result was that it took a few minutes longer for it to signal it had reached 350, but it still was way of shy of the mark. Called in for servicing again, now they changed out the control board as well as the sensor in the oven, afterwhich time the repairman said that if this didn't work, he was out of ideas, he could do no more. So of course the issue was not remedied and after a month or so (after yet another baking disaster) I once again called GE. They sent out another service guy from a different company, he brought his 4 oven thermometers, I had mine in as well, and sure enough he too confirmed that the oven was far too slow to warm up ( over 45 minutes to finally achieve 350 degrees) despite signalling that temp was achieved at the 9 min. mark. GE just called me and said basically that the range is working as it should. Does this make sense to anybody? Is there anyone who has or is experiencing this same issue with this oven? Our guess is that it is a design flaw...the sensor is located too close to the upper element of the oven and hence prematurely (by 150 deg) that 350 has been reached when in fact that temp would really take 45 mibe achieved. Any thoughts?




  • Les Garten

    Well, that's one way to deal with the problem that heating these ovens up kills them...


    Don't let 'em heat up, Genius!

  • mnovak99

    It would be nice if someone on this site with the GE Profile model like yours could run a quick temp test for you. My guess is they all have the same problem but maybe not. I have the GE Cafe model with double ovens. So not really much help to you but here it is anyway. Upper Oven (smaller) set to 350 signals it has reached temp in 8 min. Actual temp is 295. At the 11 min mark it reaches 350. Lower Oven (large) set to 350 signals it has reached temp in 8.5 min. Actual temp is 330. At the 10 min mark it reaches 352. Both respectable. All temps were measured with a probe on the rack in the center of the oven. Both ovens have hidden bake elements.

    If I were you I would play around with the calibration a little using your oven thermometer to verify any changes. I never had the need to mess with mine. It did seem counterintuitive to decrease calibration but who knows. Here is what the owners manual for your model says:

    " The oven temperature can be adjusted up to (+) 35F hotter or (-) 35F cooler. Touch the number pads the same way you read them. For example, to change the oven temperature 15F, touch 1 and 5."

    The GE manual warns not to use grocery store oven thermometers but your yours sounds like it was verified by the ones the repairman had.

  • Les Garten

    I have one of the models above with the sudden death issues. All parts were replaced on original, Still never worked, the fork lifted a new one in. It has had issues that I fixed myself.


    I've cooked in mine with laboratory grade probes in and out of the meat, and was very satisfied with the temperatures. Mine works well... when it works

  • HU-427301827

    I have, or I should say it has me a GE Induction oven model # CHS983SEL2SSS. A few months old and many thousands of dollars and it fails... the burners shut off after about 10 seconds and the fan runs constantly. No error codes are present. I didn't want to buy this after our expensive GE refrigerator failed after a few years but my wife loved the look. I think with GE appliances you need to spend extra for backup- put a freezer in garage and buy some portable cook tops; not GE of course.

  • HU-427301827

    If you don't own GE then don't start. If you do own then repair and sell.... stop the bleed.

  • campari_tonic

    I bought a GE Model CHS 995 DEL 2SS slide-in induction range in Mid October 2018 and it started to fail two weeks later. Same problem, it would just quit for no apparent reason, service was abysmal and it took a letter to the GE CEO before we were put in touch with someone at their corporate office who started to handle the problem more efficiently. Several service calls were cancelled by GE on the same day, leaving us hanging with no Christmas dinner and no cooking ability for New Years. GE finally admitted that they had issued a service bulletin on this model (that's why it took forever to get parts, as they were always out of stock). We have endured a number days of long waits for visits by GE technicians attempting to render the range functional by replacing several parts and after it failed again, now -- after 4 months -- they have finally agreed that the range is a dud and has to be replaced. The problem is that there seems to be an inherent problem with their induction elements and I am attempting to make acceptance of a replacement range conditional on GE's assurance that, should I experience the same problem with the replacement, I will not be required to again endure repeated repair attempts, that the range will be returnable and I be issued a refund of the purchase price. Good luck with that -- since I have already been told that should I decide to pick a lower priced model as a replacement (because I don't trust the quality of the first one) they would not refund the difference in purchase price. I have lost confidence in GE appliances and their service.

  • Les Garten

    My advice anyone, if you are still under warranty, cite this thread, and demand your money back. This needs to be a class action lawsuit.

  • HU-427301827

    If the stove was like 300 bucks I'd almost accept the flaw... but not $3400.00. I'd go in on a class action but only if I actually got something for my trouble.

  • mnovak99

    campari-tonic

    So they won't refund the difference if you go for a less expensive model. Would they be willing to deal is you go for a more expenive model? My advice would be to go for the GE Cafe induction model. I had mine over a year and it has been rock solid. There is also a thread going on Houzz about that model.

  • HU-427301827

    Got diagnosis... power board failure. Unusual on new machine but glad on warranty. Wholesale price is ~$650.00... installed would be ~$1500.00.

  • Les Garten

    That sounds like the problem I had with mine, the most recent problem that is. I bought the board new off Ebay for $158 I think and put it in. Is that board in the lower backside down where the power comes in?

  • C Lane

    For anyone who needs these boards for the PHS930 model, I have a new set in the boxes from GE - front control panel as well as master board for burners. They were intended for a warranty repair, but were so back ordered that GE ended up replacing the range. These showed up the following month and GE declined to provide an RMA!

  • HU-89542747

    I'm getting the dreaded FA93 errors every other time I use my stove so I guess I'll need a new board. If you still have one available, I'd love to buy them off of you.

  • C Lane

    And I'd love to help you out!-) I have these still new in the box. I just followed your profile so you should be able to message me privately now to exchange the details.

  • HU-89542747

    Thank you! I pm'ed you.

  • Suzanne Benning

    I have had (and loved) my GE Profile PHS920SF1SS for 5 years but began have problems after 4 years. For the last 1 year I have had the same issue about 5 or 6 times. When I boil a big pot of soup or a canner for 2 to 3 hours, then the the stove top shuts off, need to remove pots and wait for it to cool down, then it works again. Was very manageable and not a big deal....until last week. Now it shuts off after anywhere from 20 to 60 minutes and pretty much every time I cook. Totally unreliable now. Thanksgiving this weekend will be interesting. Repairman came today and we both think part of the problem is that the fan no longer works in the cooktop (cannot hear it and when I think back I think we used to be able to hear it) so when it gets to a certain temperature, it shuts down. When he checked the stored error codes they were 1.FA00 2.FA00 3.FA00 4.FA47 5.FA00 (1. is the most recent, 5. is the oldest) He seemed concerned that because it has taken so much heat in the last year that perhaps the induction board/assembly should also be replaced. Thoughts??

    $1400 for replace and installation of board (includes fan)

    OR

    $467 for replace and installation of fan alone

    Other people on this thread have mentioned FA00 but our issue seems to be different. jakret above is the most similar.

    Other notes from the repairman:

    - He would never buy induction as he has seen so many issues and at 5 years with ours, he thought we were doing really good! However he did say they have done more repairs on other brands.

    - Suggested to never use the self-clean as a lot of the components have plastic and he thinks it could be wreaking havoc.

    Any suggestions or comments are greatly appreciated

  • Les Garten

    Invest almost $1900 into this piece of Junk? Where do you live? I need to come over there and do some emergency Electro-shock therapy!

  • Suzanne Benning

    i know seems like a lot of money but the stove cost 3000. the repair would be 1 or the other, not both.

  • Les Garten

    There's other things that can go from heat, lots of stuff. Also, I had to replace the power relay in the back, probably heat damage. Luckily, I found a part on Ebay and did it myself. I guess what I'm getting at is that these units have CONTINUAL problems. So, you're looking at spending 50% of the cost of the unit, and I can tell you, you'll be back here again. The people that repair these things have no idea how to fix them, I mean no freaking idea. They just replace parts hoping the problem will go away. Then, the heat related problems will come back, the replacement parts are no better than the originals. These units are poorly engineered, and cannot be repaired. The first one I had, failed right off the bat. They replaced multiple boards, multiple times for months, every week a new part. I had the first one delivered right before Thanksgiving. Guess how my holidays went? Then they fork lifted it out, and brought me another unit. They gave up on it, they couldn't fix it. The new unit has had some of the same problems. I've had 2 units, multiple boards, and 100% failure of these things. I do believe that the self cleaner, kills them, along with using them that is. There should be a class action law suit on these. Probably not enough sales to justify it to the lawyers though.

  • C Lane

    I agree with Les - cut your losses. There seems to be a fundamental design flaw with regards to the airflow through the control board space and the thermal shielding of those boards. Once they start overheating, you run the risk of damaging chips and other small components on the board that are impossible to repair. If you can find the blower fan (AVC #BA12032B12H) online and feel comfortable spending a couple of hours swapping that out, you may solve your problem inexpensively. However, I wouldn't gamble $1400+ on swapping out those boards. (I had a similar issue with the 930 model and was fortunate that GE had a 6 week backorder on parts so they ended up replacing the entire range.)

  • Les Garten

    C Lane has it exactly. As soon as I can't repair mine cheap, it's on the curb. I couldn't even sell this to someone, I have a conscious. If you can get parts on ebay and fix it yourself, string it along a while. I would not spend over $500 on mine for sure. Not entirely sure I would do $500. Last part cost me around $75 I think

  • kevinande

    If the fan is the only problem, if your capable of pulling the board your self, pull it and find the part# on the fan. I bought one for $27.00 and put it on a board declared bad by a technician and it worked just fine after the fan was replaced. May or may not be worth it to you, however it is an option.

Need help with an existing Houzz order? Call 1-800-368-4268